[ previous ] [ Contents ] [ 1 ] [ 2 ] [ 3 ] [ A ] [ B ] [ C ] [ D ] [ next ]


Debian Tcl/Tk Policy
Chapter 3 - Tcl/Tk Programs


3.1 Version Independent Programs

Programs that can run with any version of Tcl/Tk should be started with #!/usr/bin/tclsh or #!/usr/bin/wish. They must also specify a dependency on default packages tcl and/or tk. You're free to use #!/usr/bin/env tclsh and #!/usr/bin/env wish, if you'd like to give the user a chance to override the Debian Tcl/Tk package with a local version.


3.2 Version Dependent Programs

Programs which require a specific version of Tcl must start with #!/usr/bin/tclshX.Y. They must also specify a strict dependency on tclX.Y. Programs which require a specific version of Tk must start with #!/usr/bin/wishX.Y. They must also specify a strict dependency on tkX.Y. Again, if you're using #!/usr/bin/env tclshX.Y, or #!/usr/bin/env wishX.Y please be aware that a user might override the Debian Tcl/Tk packages with a local version and that release default packages can change also.


[ previous ] [ Contents ] [ 1 ] [ 2 ] [ 3 ] [ A ] [ B ] [ C ] [ D ] [ next ]


Debian Tcl/Tk Policy

version 0.3.0

Francesco Paolo Lovergine frankie@debian.org
Sergei Golovan sgolovan@debian.org