[ previous ] [ Contents ] [ 1 ] [ 2 ] [ 3 ] [ A ] [ B ] [ C ] [ D ] [ next ]


Debian Tcl/Tk Policy
Appendix A - Build Dependencies


Build dependencies for Tcl/Tk dependent packages must be declared for every Tcl/Tk version, that the package is built for. In order to build for a specific version, add the versioned Tcl/Tk packages dependencies; it is generally better and recommended depending on the appropriate default packages with an eventual strict or relaxed versioning.

Extension packages and applications which link to Tcl/Tk libraries should depend appropriately on one or more of the following packages (with or without additional package version relationships):

     	tcl-dev
     	tk-dev
     	tclX.Y-dev
     	tkX.Y-dev

For example, tclreadline build dependencies are the following:

     	Build-Depends: debhelper (>= 8.0.0), dpkg-dev (>= 1.16.1~), tcl-dev,
     	 libreadline5-dev, autotools-dev

Module packages, script libraries and Tcl-only applications should depend on the

     	tcl
     	tk
     	tclX.Y
     	tkX.Y

For example, tcllib build dependencies are the following:

     	Build-Depends: debhelper (>= 8.9.7)
     	Build-Depends-Indep: tcl

Due to limitations of current autobuild daemon it is forbidden to use build dependencies on the virtual packages libtcl or libtk only. These dependencies cannot guarantee consistent build environment, so it is mandatory to prepend a preferred Tcl/Tk version before each of the virtual packages.


[ previous ] [ Contents ] [ 1 ] [ 2 ] [ 3 ] [ A ] [ B ] [ C ] [ D ] [ next ]


Debian Tcl/Tk Policy

version 0.3.0

Francesco Paolo Lovergine frankie@debian.org
Sergei Golovan sgolovan@debian.org